注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

且行且记录

点滴记录,行的更远!

 
 
 

日志

 
 

概括一下  

2014-05-16 13:54:47|  分类: 方法技巧 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

以前非常喜欢溢出类漏洞,直接就可以把目标拿下,但是溢出类漏洞很容易失效,

补丁一打,系统升级就都失效了。

现在我觉得还是非溢出类漏洞,比如弱密码、配置错误、注入,信息泄漏、欺骗、dll劫持等,

这些以前比较忽略的漏洞倒是现在安全的主要问题。

远程执行漏洞的目的是为了获得一个执行shell,哪怕是最低的权限。

这种漏洞的边界就是计算机,能够从无到有获得目标shell。

以前这个主要靠远程溢出类漏洞,现在溢出类漏洞很难利用,几乎成了拒绝服务漏洞。

现在服务器类方面的漏洞主要靠一些应用类程序的配置错误,注入,上传文件等。

客户端漏洞主要是IE、Flash、PDF、Word、等漏洞,要被动等待上钩才行。

主要是IE可以通过脚本,利用释放后使用这种类型的非溢出类漏洞达到远程执行。

本地漏洞的目的是为了提权。这种漏洞的边界是进程,能够从低权限到高权限转变。

客户是不会主动访问你的,如何使他访问你?这个主要靠欺骗,局域网可以ARP欺骗,

这是局域网欺骗的基础,通过它其他欺骗很容易达到。远程欺骗这个估计要靠DNS的漏洞了。

08年好像有DNS缓存中毒漏洞。

  评论这张
 
阅读(27)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017